The dreaded stutters again

RoF developed the dreaded stutters again and I’ve been through numerous options to try to fix it - new and old gfx drivers, all options to min etc but it made no difference.

Fired up CoD this morning and noticed the same issue. Approximately every second there’s a stutter. If I watch an aircraft with outside view I can see the prop stutter when this happens. With the in game fps counter on I notice that the fps count goes from a steady 60 to 45 very briefly when these stutters occur.

My guess is there’s some sort of timing issue somewhere but I don’t really know how to try to isolate the fault. Any hints or tips gratefully accepted.


Think back to when it has started. What have you installed recently. Alot of games have DirectX installs, particularly older games. Any windows updates?

If all that’s a no, then run your favourite spyware tool and antivirus. Delete all cache and temp files, defrag and re-test.

Thanks Keets, been racking my brains for something but nothing comes to mind. Tried all the usual stuff as you suggest but nothing obvious.

Interestingly IL2FB does not exhibit this behaviour - rock steady solid FPS.

Back to testing.


Sounds like RoF settings. Try setting v-sync on with a max fps of 60 in the RoF graphic settings tab.

Makes no difference Brigs. Even with all settings on minimum the issue is still there which suggests it’s not a simple graphics issue. And as it affects both RoF and CoD it’s not just an RoF issue.

I’ve tried everything I can think of including a restore point to when it was OK but it didn’t work.

After Thursdays SE, I’ll be going for a Win7 re-install on Friday which will hopefully solve the issue.


I’d still bet its an issue with your Direct X install.

CloD and RoF both make use of DX, whilst with IL2 you’ll be using OpenGL.

Yes that may be it Keets, we’re suspecting that you did not successfully run the three helper programs that come with a standard RoF install WB. There’s a Visual C/BASIC app (I think, something like that) update and a NET framework update and a DirectX update, all three of them must be run to completion at install time (do not dismiss the DirectX update installer)

Re-installing RoF ought to fix it if that’s what it is WB, or run those three ‘helper programs’ again over the top of your current install


Win7, RoF and CoD all re-installed and problem solved. Still don’t know what caused it though.

For info Ming, I always ensure those additional programs are installed whenever I have to re-install.

Cheers all,


Here’s a short vid of the problem - watch my plane appearing to ‘skip’ every second or so:

Fixed with a re-install of the DirectX 9.0c software. I had to find and download the whole runtime installer directx_Jun2010_redist.exe at rather than the dxwebsetup.exe which is the web installer.

When running the web installer it recognised updated DirectX drivers and would not install.



Told you it was DX. :wink:

Glad its sorted.