Problems with servers incorrectly finding "unclean" files in my DCS

Got this tonight on our B-server (Channel map), but get similar things when I have tried to joing 4YA. Totally clean install (though old), but no mods or add-ons or anything. When I restart DCS it will say that the installation is clean, but once a server have kicked me out, it will show the red shield.

So, after this I deleted the file that was said to be the problem, and then I ran the repair (with the thorough scan), then started up again, and got an error for exactly the same thing. :frowning:

First things firts, have You tried a repair? In my opinion some cluster of Your drive probably went corrupt and this change the size of the textures file. As client checker look for time stamps, index file and size, could be that You were kicked for this. So check the drive for bad clusters (under windows) and after make a repair. You could use skate zilla good utility for this.

Everything is on SSD, and yes, I have run the repair several times, does not help. Seems to only happen with some servers. A-server was ok on monday (haven’t tried today), and I don’t think I have ever had this problem on that one. 4YA on the other hand is impossible for me (at least the times I have bothered to try to join it). It’s very clear that the repair function of DCS isn’t able to fix this.

Try look here :

Unfortunately no solution in that thread, but I added my problem to the list…

1 Like

Well, I hope this is finally fixed now. As a ED Betatester, Flappie, suggested, I:

  1. Go to “.\DCS World\Bazar\World”
  2. Delete the “Shapes” folder.
  3. Run a [DCS repair]. (I did a full repair checking everything)

And after this I could actually join 4YA and fly for a while (until I ripped a wing of my Spitfire, feels like it has become very sensitive for that again since 2.8 or so, or I’m just imagining after little flying over the summer)…


That fixed it for a while, then after the latest patch it started to act up again, and now it seems like there’s a problem every time I fly. I tried the same fix, but it came back. Now I’m running a deep repair again, and now it says that it’s downloading a 53Gb update. If it doesn’t work after this, I might have to do what some have suggested and uninstall/reinstall…

Well, this is kind of, interesting…

Well, it kept going until it said it couldn’t get any further, I think it was around 200 Gb by then.
I also tried to update my graphics drivers and ran into problems…

greeeemlins :scream::scream::scream::scream::scream:

I wonder if it’s MS trying to fuck with me so I start considering Win11… (Not really working btw)

The graphics drivers problem was Windows blocking the new drivers. I ended up turning off Windows “protection” to install them, and now it seems to be working good. And I could do a proper repair of DCS, worked good with my server last night at least, have to try more before I know if the problems is totally gone, but at least I got up in the air (and managed to wipe out a column of T80 tanks with support vehicles in one pass with 5 CBU-97’s :smiley: ).

Well, tonight when I tried to start DCS to have it update to latest patch, I got an error message that it couldn’t run (the DCS_updater.exe that is), DCS.exe worked, but that doesn’t give you any updates…
So I made the install I had into a backup, and now I’m installing DCS fresh…

Mikke don’t tease us! is it working??

Seems to be now. Just have to set up all the controls etc, but I am hopeful…

1 Like

And since the update tonight the problem is back, model for the Patriot this time! :rage:
I have removed the files I suspected and running a repair now.