Game BUG Help please

I can no longer see the briefings in downloaded war missions when I am hosting. As you can imagine this is very inconvenient. I have made no changes to my system other than installing IL2 Stab, which I have also setup to load TIR, TS and HL when stab starts. I have checked the AW missions that I have downloaded in the FMB and the briefings are definitely there and the other players who have been in the missions that I am hosting can also see the briefings. I have flown in a mission someone else was hosting and I could read that brief just fine, but I cannot read the brief in a mission if I am hosting it.

Anyone got any clues? Thanks in advance.

I can’t help you I’m afraid, but I think Mas get the same problem (at least sometimes). I have a vague recollection of having had something similar a long time ago, must have been during the time of the first IL-2, but I can’t recollect what corrected it, if it was a new patch, or of it was a reinstall.

IIRC Mas have tried reinstalling to fix his problems, but I don’t think it helped.

Sorry I can’t give you something better to go on…

That’s correct Mikke.
try for help everywere without any sucess, reinstall my comp but not a fresh clean install of PF. Use a backup that have been working before but the breifing problems were still there.

It seems some of my new coops give me problem to read the breifing but some works …very strange and annoying of course so if you find anything Classic please let me know.

sorry that you have the same problem and i hope it’s a solution for it.

It seems we are afflicted with a rare disease Mas, I have posted this message but I have also tried in the Air War forums, the IL2 ubisoft forums and SimHQ but no-one can tell me a correct answer. It must be something specific to our machines because other players can read the brief and I can read the brief so long as I am not the host. Very very strange.

Can I ask, do you use IL2 Stab??

no i don’t

and i have also look for help in UBI forum without sucess.

i wonder if it can be something in config.ini file ???

i copy that file and all mys skins and missions when i reinstall

hhhhmmmmm… thats got me thinking, I have a backup of the conf.ini file, I will compare them, it could take some time though

Ok so I have removed the conf.ini file from the equation, first I tried using my 4.071 '46 conf.ini file but still had the same problem. I then tried removing the conf.ini file so that 1946 would write itself a new one upon starting and still had the same trouble, and finally I used Joes conf.ini file and still the blasted thing will not work :mad::mad::mad::mad::mad:

Try posting the mission file which you lose the briefing and I’ll host it and see if I get the same thing.

Just thinking of this from the other side, it could be a mission problem with the generator. :slight_smile:

The mission downloaded to us is buffered from the generator though by Classic’s machine

Have a look at your File Associations Classic and associate dot mis and dot properties files with Notepad rather than Wordpad or some text editor that might do something to those must-be-simple-text files

Keywords: straws, clutching, correct


I’ve looked at the file associations and they have not changed for months, but I have noticed a problem shown below. The PROPERTIES files have always been associated with wordpad and the MIS files have always been associated with notepad, that used to work fine for me. But evidently something is going wrong somewhere so I changed the association of the PROPERTIES files back to notepad. But there is something very wrong

Below is an extract of my properties file when opened in notepad

[i]Short Mision badc_29718
Sun Jul 22 04:18:34 2007

Description <ARMY NONE>

Mission Badc_29718
Sun Jul 22 04:18:34 2007


Select your aircraft and check Briefing.</ARMY><ARMY RED>
Weather -> Good clouds at 1200 meters.


It opens the sameway in wordpad.

Looking at that I think it could be a problem being created by Microsoft Word, for some reason the other day I remember trying to open a PROPERTIES file with Microsoft Word, when I tried to open the file I got a message as below

Ok further testing has thrown more spanners into the works :smiley:

I thought I would try running my backed up before the upgrade 4.071m version of the game. Loaded the same missions into the launch folder and honestly expected the same results, as I had half concluded that this is a problem stemming from windows, however I was most surprised when I hosted the missions in my 4.071 game that I could read the briefs just fine.

insert pulling hair out smiley

Can you post a link to the mission though Classic?

IL2 is opening the file, so your file extensions or what you do in Windows shouldn’t affect it.

Though if you really want to check the file extensions:

  1. Open regedit (Run>regedit)
  2. Drill down to the key: HKEY_CURRENT_USER-> Software->Microsoft->Windows->FileExts

there is likely one called properties

Under this will be something called OpenWithList

See what’s listed

I can no longer see the briefings

IL2 is opening the file, so your file extensions or what you do in Windows shouldn’t affect it.

If the briefing isn’t being seen, how do we know that Il-2 is opening it?

When we see it it must be loaded but Classic isn’t seeing it which implies it isn’t being loaded. Or we’d see it? Must be a flaw in that logic somewhere fair enough :slight_smile:


Can you post a link to the mission though Classic?

Yep, sorry mate, links below, they are at the top of the pages

Though if you really want to check the file extensions:

Checked the extensions, well I say checked I followed the path you suggested which was more or less correct and found a list of extensions and .txt files are opened with notepad, I’m certainly no master of the registry though :slight_smile:

When we see it it must be loaded but Classic isn’t seeing it which implies it isn’t being loaded.

Yep total confusion reigns supreme :smiley:

I cannot understand it, everyone else can see the brief, but I cannot. As I am the host my fellow players are only reading the brief of the mission that my PC has passed to them so why the bl**dy hell can I not see the brief??

I’ve just created a copy of my backed up 4.071 folder and I am about to upgrade it to 4.08, will see if things go back to normal after that.

I’ve just run through the three missions there and the briefings are visible if I host, which rules out a generator issue.

When you go to select the mission, is the “short brief” i.e the bit which tells you who planned the missions etc visible?

One thing you could try is installing Shift_E’s Quick mission Tuner. This changes the association such that QMT opens the mission files and will remove the association from Wordpad and Note pad. It might help.

If it doesn’t work, you can always de-install it.

Ok I have solved the problem, I have not fixed the problem as such, but I saw the wall and walked around it rather than knocking the bloody thing over, which is really what I wanted to do.

I renamed my ‘IL2 1946’ to ‘IL2 1946 BORKED’ then I copied my ‘IL2 1946 4.071’ and renamed the copy ‘IL2 1946’ then I ran the 4.08 patch again over the new IL2 1946 folder and upgraded it to 4.08m. I then hosted the coops to check the briefing and all worked as advertised, trouble was I was using an old conf.ini file so to test it fully I took my previous IL2 1946 4.08 conf.ini file and copied it across to the new 4.08 folder and tried to host again, I had this time expected trouble but to my complete surprise it all worked as advertised. So I am now back on an even keel I think, I dont know what the problem was and I dont know how to fix it, but I do know that I no longer have a problem.

Would still be nice if it could be fixed, for Mas’ sake if nothing else.


Why did I have to say anything?

The first time I ran the new 4.08 it all worked fine, but I just tried it again and its forked again :mad:

I know I should probably not say it but I’m fixed again.

When I copied across the mission, skins, records and users folder to my new 46 folder I took my war missions to launch folder with them and its something thats happened to those files because they would not work. Having created a new war mission to launch folder and extracted the files fresh from the .zip they seem to work again.

Just skimming here, but it looks like NTFS permissioning on the files to me. Make sure the folder and all child objects are set to full control for the “everyone” group.
Edit: Looked at the thread properly… ignore me. XP at home doesn’t have such stuff.