Computer is kaput

Ok - long story short. After waiting 20mins+ to load up Blue Flag on Sunday, decided to add more RAM (currently on 16 Gb) to see if that cures DCS MP hanging on those busy/more complex servers.

Checked motherboard specs (P67 Sabertooth) - DDR3, up to 32Gb and 8Gb+ allowed on each stick - and MB supposedly has a ‘easy RAM’ compatibility tool built in to make it even simpler. No brainer, right?

Ordered 32Gb (2 x 16GB) of RAM. Last night tried it - refused to boot up. Tried ‘easy RAM boot-up’ button on motherboard. Nothing. Tried re-inserting old RAM. Same problem. Fans spinning, red light on motherboard but no boot-up.

Obviously I forgot the ‘golden rule’ of PC flight simming. If your computer is working fine(ish) and you are having fun - DO NOT MESS WITH IT.

Exhausted my knowledge on this one, so unless anyone has got any (v simple) fixes, its off to the PC hospital to see a) if is can be fixed b) worth fixing. (its an ancient i7 2600k which has been struggling recently - not just with VR/DCS but everyday tasks too).

Reinstall your old ram, the reset the bios back to defaults. reboot, go back into Bios and check if the ram has been picked up and at the right speed. Might need to actually adjust the ram speed in the Bios. If that works, and back up and working, i’d try the same with the new ram.

Cheers. Will give that a try (Hold F2 down and hit power?).

Old RAM is in but wasn’t booting. I’m not even seeing BIOS screen or any options - just black screen (monitor is plugged in).

Sounds like you either accidentally unplugged some power cable, or (worse) fried something in the process of installing the new RAM. :frowning:

What RAM did you buy? If you end up getting a new MB+CPU you will most likely need DDR4 for it.

without any module inserted, do you hear a sequence of beeps when you power on?

Hmm, I think your MB might be limited to max 4x 8Gb RAM =32Gb (my Sabertooth Z87 is according to the manual)…

Hmm, I think your MB might be limited to max 4x 8Gb RAM =32Gb

Could be issue. 2 x 16Gb sticks instead of 4 x 8Gb. Although online specs/manual say its rated to 8Gb+ per stick. Frustrating!

Still, I don’t see how that could kill it. Not working with that memory, sure, but not working after switching back to the old? :confused:

Update. Still dead. Holding F2/F4 down while switching power on didn’t make any difference…

Hmmm that looks like motherboard issue, either it died or bios needs refresh clearing CMOS.
You can try this:
1.remove bios battery and hold power button for 1min while pc unplugged (no power).
Than put back battery and try to start it up.

  1. There is 3pin connector with 2-pin jumper on motherboard, switch the jumper on free pin and middle one, start up pc, shut it down and put jumper back as it was before.

Here is described more detailed;

Good luck buddy!

Cheers Ribbon. Will give that a try.

At limits of my IT knowledge now so if this doesn’t work its off to repair shop.

Update - rebooting/resetting BIOS to factory default didn’t work PC now at repair shop…