COD - Hanging PC on exit

Hi Chaps,

Been getting COD running nicely on my new rig but every time I exit the game to Steam Steam.exe and Explorer.exe stop responding.

Neither process can be killed via task manager (you can click to kill them but they won’'t die…)

I can attempt a shut down and the machine hangs on the Logging Off screen…

Any ideas or anything anyone has heard of?

Windows 7 64bit
i-7 2600k @ 3.4ghz
AMD 6950 GFX Card on latest drivers (still happens on previous version)

Windows 7 64bit

Dear reader be sure to run all programs/apps in Administrator mode on this operating system, even if you are the Admin of your machine

Find the executables, right-click for Properties, set Run As Admin mode (and maybe set a Compatibility mode)

There’s a ‘Disable Desktop Composition’ setting in the Compatibility tab, try ticking that if an application hangs on exit


Thanks, Ming. I’ll give that a try.

Not had any issues with other Steam games, or any others for that matter and I can’t find anything like it on Google. It’s very odd…

Annoying too because every attempt involves a hard power down on the PC which isn’t ideal.

Insight have you checked their website…link to follow as at work and blocked…doh.

1c site that is.

Also let us know when you’re about and we can have a fly about in CoD.

Cheers, Swoop

I hadn’t checked the 1C site. Just the Ubi one - will take a look :slight_smile:

Anyway try to turn off the Aero desktop (as well as the Admin thing), that’s my thought as it’s a hang on backing out of an application

Aero should be auto-disabled on running a game the legends say but there’s odd stuff happening with some graphics cards

Try windowed mode too, see if you note any difference

you can click to kill them but they won’'t die

Try going into Processes rather than Applications to find and kill it, seems more responsive to torpedoes


Yeh, windowed mode is a good idea to try - when I get round to it again, I will try one thing at a time so hopefully I will know if any one of the things fixes it.

I never kill applications from the Apps tab, always directly through processes :slight_smile: more responsive as you say.


Tried all of the above with no joy.

Interestingly (and annoyingly) the game gave me hope when I tried playing a track and then exited the game as it worked.

I played a full single player mission and exited and it did exactly the same thing and died :frowning:

Every other process in task manager (processes tab) is killable except for explorer.exe and steam.exe


How annoying :frowning:

Will try posting on the 1C site to see if anyone has any diagnostic type stuff I can run to establish what is happening.

I emailed Steam support about it. They emailed me a link to a page about updating drivers (despite telling them in my email that they are all up to date), brilliant…